Documentation

 

 

Description

This hotfix resolves the issue for SecureAuth IdP versions prior to 7.5 in which users receive a .NET error during the pre-authentication portion of the workflow in environments using an ASPNETDB datastore with device fingerprinting.

This error appears because the ASPNETDB datastore lacks full support for the Fingerprinting functionality.

Hotfix Release Date: February 21, 2014

Applies to

SecureAuth IdP 6.0 - 7.4.x

Resolution

These steps explain how to update SecureAuth IdP code files that can impact the operation of an appliance. For added protection, back up the files before updating them. In this manner, the original files can be restored in the event a problem occurs. If unsure about executing the update or if problems are encountered during this operation, contact SecureAuth Technical Support.

To resolve this issue:

  • Upgrade to SecureAuth version 7.5 or greater

- or -

  • Apply the hotfix available to address this issue in SecureAuth IdP versions prior to v7.5 
    1. Download the hotfix for ASPNETDB and Device Fingerprinting Support
    2. Place the .DLL file in the bin folder of the affected realm(s)
    3. Run the .SQL script on the ASPNETDB database